Luis Santamaria

Hide Component on Frontpage

4 posts in this topic

Hi,

possible to do that, please open file: ...\templates\bt_travel\tpls\default-content-left.php

find:


<?php $this->loadBlock ('mainbody-content-left') ?>

change it to:


<?php if ($menu->getActive() == $menu->getDefault($lang->getTag()) ) : ?>
<?php $this->loadBlock ('mainbody-content-left') ?>
<?php endif; ?>

or you may download this file and replace it in: ...\templates\bt_travel\tpls

default-content-left.zip

Share this post


Link to post
Share on other sites

This isn't working. the best way is to copy the template, assign home to it and then set the layout to default-component -right . then remove


<?php $this->loadBlock ('mainbody-content-left') ?>

from \templates\bt_travel\tpls\default-content-right.php

Share this post


Link to post
Share on other sites

Hi,

try to open your menu item, in page display option, add page class, and then, open file: ../templates/b_travel/css/custom.css file, add:

.YOUR_ADD_CLASS .t3-content{display:none;}

Share this post


Link to post
Share on other sites