Mary

error when saving to back end

15 posts in this topic

I am trying out this nifty plugin.. and when saving from the backend I get this error

Warning: require_once(/home/devfwm/public_html/fusionweb/administrator/plugins/system/bt_shortcode_system/shortcode/core/generator.php) [function.require-once]: failed to open stream: No such file or directory in /home/devfwm/public_html/fusionweb/plugins/content/bt_shortcode_content/bt_shortcode_content.php on line 8

Fatal error: require_once() [function.require]: Failed opening required '/home/devfwm/public_html/fusionweb/administrator/plugins/system/bt_shortcode_system/shortcode/core/generator.php' (include_path='.:/opt/php53/lib/php') in /home/devfwm/public_html/fusionweb/plugins/content/bt_shortcode_content/bt_shortcode_content.php on line 8

I am using Joomla 3.3.6

Share this post


Link to post
Share on other sites

Hi Mary.

Thanks for using our extension.

BT Shortcode is a package of 3 plugin

BT Shortcode Content

Bt Shortcode Editor-xtd

And Bt Shortcode System.

Please try to re-install the package or check if Editor-xtd and System plugins are installed.

Thanks again.

Share this post


Link to post
Share on other sites

Mình cũng bị lỗi như mary dùng cùng phiên bản 3.36 sau khi lưu nội dung bài viết ra trang trắng xóa. Sau đó mình bật thông báo lỗi trong hệ thống thì lỗi cảnh báo này xuất hiện. Xin được sự trợ giúp.

Warning: require_once(C:\Program Files (x86)\VertrigoServ\www\Giaoduc\shapernewsiii\administrator/plugins/system/bt_shortcode_system/shortcode/core/generator.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: No such file or directory in C:\Program Files (x86)\VertrigoServ\www\Giaoduc\shapernewsiii\plugins\content\bt_shortcode_content\bt_shortcode_content.php on line 8

Share this post


Link to post
Share on other sites

Please help! I tried to uninstall and reinstall again. But the following error message:

Warning: require_once(C:\Program Files (x86)\VertrigoServ\www\Giaoduc\shapernewsiii\administrator/plugins/system/bt_shortcode_system/shortcode/core/generator.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: No such file or directory in C:\Program Files (x86)\VertrigoServ\www\Giaoduc\shapernewsiii\plugins\content\bt_shortcode_content\bt_shortcode_content.php on line 8

Check the path as the error message I still find the file: 'generator.php' in folder /plugins/system/bt_shortcode_system/shortcode/core/generator.php)

Please help me....

Share this post


Link to post
Share on other sites

Chào bạn.

Thực ra mình cũng chưa rõ tại sao lại có lỗi này, bởi vì BT Shortcode này là 1 bộ 3 plugins và cả 3 sẽ được enable ngay sau khi cài đặt nên lỗi này chỉ xảy ra khi mà người dùng install từng plugin 1 mà sót đi cái plugin system.

Vậy bạn đã fix nó như thế nào có thể cho mình biết được không.

Thanks.

Hi.

In truth, i don't know why there is this error, because BT Shortcode is a set of 3 plugins and all of them are enabled immediately after installation, so i think this error only appear if user installs plugins one by one but doesn't install bt_shortcode_system.

How did you fix it?, please tell me.

Thanks so much.

Share this post


Link to post
Share on other sites

Same problem over here. When saving an article the sreen goes blank with:

Warning: require_once(/home/easyw/domains/easyw.wrhg.nl/public_html/hardfys/administrator/plugins/system/bt_shortcode_system/shortcode/core/generator.php): failed to open stream: No such file or directory in /home/easyw/domains/easyw.wrhg.nl/public_html/hardfys/plugins/content/bt_shortcode_content/bt_shortcode_content.php on line 8 Fatal error: require_once(): Failed opening required '/home/easyw/domains/easyw.wrhg.nl/public_html/hardfys/administrator/plugins/system/bt_shortcode_system/shortcode/core/generator.php' (include_path='.:/usr/local/lib/php') in /home/easyw/domains/easyw.wrhg.nl/public_html/hardfys/plugins/content/bt_shortcode_content/bt_shortcode_content.php on line 8

redownloading and installing does not help.

Please help.

Share this post


Link to post
Share on other sites

Hi Hans.

In truth, i'm still not sure about this problem

But please use this solution, open file /plugins/content/bt_shortcode_content/bt_shortcode_content.php

Find this line

require_once (JPATH_BASE.'/plugins/system/bt_shortcode_system/shortcode/core/generator.php');

Change JPATH_BASE to JPATH_ROOT

Gerard Franken likes this

Share this post


Link to post
Share on other sites

Good Morning,

I installed BTShortCode and when I created a new article I found, at the bottom, the icon for the use of it. I ended the article by entering the short code "Table" but I can not save the article because joomla gives me the message: "Save failed with the following error: Another article in this category has the same alias." I tried to change the title and alias but the problem remains the same. I tried it with the solution of the modification suggested by tronghm, but I have not solved. Use jomla 3.3.6. Could you give me some advice or a solution? Thanks for your kindness. Patrizia

Share this post


Link to post
Share on other sites

Hi Patrizia.

I don't think that problem relate to Bt Shortcode.

Please try to disable BT Shortcode (3 plugins : system, editor-xtd, content)

Then try again.

Thanks

Share this post


Link to post
Share on other sites

Hello, thanks for the reply. You precisely the problem after I wrote the message is that once you create a new article, when I save (only "Save" or "Save and Close") opens blank page and not the back page of the article that I was writing. The same happens when I check the "Save and Close". Nothing happens only with the "close" button that brings me back regularly to the list of articles. In short, the problem is that after saving I press the back arrow on your browser to return to the article which I had saved. And this happens whether it's using an article that use Joomla is K2. Now I disabled files BT Shortcode you told me, I created a new article that I saved with no problem, in the sense that after saving the article page reappears regularly in the back end. I rehabilitated BT Shortcode I is again the problem. Ultimately it is as if after the rescue in the back end was missing something that usually brings on the article you just saved, from which I can only go by simply pressing the "Close". I hope I have been clear. Thanks again.

Share this post


Link to post
Share on other sites

Dear tronghm, I solved. The problem was with the permissions of installed files of btshort code. I found 644 instead of 755. I have corrected and I made the change you suggested (Change JPATH_BASE to JPATH_ROOT). Now everything is OK !!!! Thank you very much for your attention.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now