federico

BT content slider 2.3.6 + BT Arise II + K2

4 posts in this topic

Hi all,

I'm using BT Content Slider 2.3.6 with left "Number of Rows" = 1 and "Number of Cols" = 3.

If I set "Number of Articles" >6 (are k2 articles) I have only 2 slide: the first slide is ok, the second have all items remained !!

For example if I set "Number of Articles" = 12, I have the second slide with 9 k2 articles in 3 rows.

Note:

- BT Arise II v1.0

- K2 v2.6.9

- Joomla 3.4.1

Thanks in advance

Share this post


Link to post
Share on other sites

Hi Federico

I think that there is problem with one in your articles.

Exactly, i suspect there is HTML Syntax error with one of them when its description is cut off.

Example.

One article has this description: Text text <span class="red">Red</span> text text.

When you set up the module with :Limit Description by Characters, Description Max Chars by 15 and "Strip Tags" by No.

The description will be cutt to: Text text <span

So the span tag is not complete.

It make HTML syntax error and breaks whole module.

Please try to increase limit number of character or change few articles to find out what article has problem.

Or to save time, please give me your URL to let me see the problem.

I will check it out.

Share this post


Link to post
Share on other sites

Hi tronghm,

you are right:

the problem is due to the fact that my k2 articles INTROTEXT begins with "<p><em><strong><span style="font-size: 14px;">text text . . . ";

so if I set "Show Intro Text" to NO in BT Content Slider settings . . . all behaves perfectly!

In my k2 articles the introtext contains about 85 words, so I set "Show Intro Text" to YES and the limit to 100 words . . . all behaves perfectly but the slider items now are too long!

So the possible solutions are:

  1. don't show INTROTEXT;
  2. show INTROTEXT having a very bad result;
  3. show INTROTEXT changing all the introductory texts of the articles so that the result is decent

maybe I will opt for the first :(

Thanks a lot

Share this post


Link to post
Share on other sites

I don't understand 2nd solution.

but my solution is use Strip Tags option, set it by Yes to remove all HTML tags in your introtext.

With this option, you still can show introtext without style.

Thanks

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now