theguy

Trigger Show Content/Hide Content on thumbnail click

17 posts in this topic

Hi,

I'm working with your tool for the first time and it's great. I've setup the Nav Type to "Thumbnails" and every thing is working as it should. My client raised a very reasonable request: he would like the content of the page to disappear at the same time a user clicks on one of the thumbnails. Basically he's asking to trigger the "Show Content/Hide Content" button along with the thumbnail click. It really does make sense if we presume that the user clicks on the thumbnails to watch the images and the content is kind of "in the way". I could not find a way to do it myself. Can this feature be added easily?

Thank you in advance,

Guy.

Share this post


Link to post
Share on other sites

Click outside thumbnails is a great idea. In addition, I do have the SHOW CONTENT/HIDE CONTENT button enabled so clicking it will be another option. If both could work together that will be best. This could be a great addition to an already great tool :)

Share this post


Link to post
Share on other sites

Hi,

Thank you for the modification. I've copied the file to the location you've mentioned and this actually caused the entire module to disappear. No background image, no thumbnails, no top show/hide content. I guess something went wrong...

Guy.

Share this post


Link to post
Share on other sites

Hello Dear,

I'm sorry to do this but I have one small fix I would like to address to you.

After the change you've made the thumbnails now works great and the site disappears just like the client asked for.

But, the right and left arrows next to the thumbnail will bring the site back on. That makes the browsing experience very clumsy as the user needs to click on the thumbnail again to hide the site. Can you please instruct me on how to apply the same rule on the arrows as well?

Thank you very much in advance,

Guy.

Share this post


Link to post
Share on other sites

Hi.

I'm confused with your problem because when the content is hidden, you can't make it appear again unless you click button show content.

Can i see the problem you on site?

Share this post


Link to post
Share on other sites

Hello and thank you again for the premium support.

As you can see in the following link, the site itself will disappear when we click on any thumbnail. But, click on the main right and left arrows or on the thumbnails right and left arrows and the site comes back again. So you see, this makes browsing through the images quite uncomfortable as the user needs to click on the thumbnails every time to hide the site back again.

Website link

Share this post


Link to post
Share on other sites

Oh.

I'm sorry.

I forgot one thing. That is block of code that handles click event to body to show content again

Please open file default.js and find this code

if(!$B(event.target).is('#thumbimgs .thumbimg img') && !$B(event.target).is('#cp-bullet span')){

change it to

if(!$B(event.target).is('#thumbimgs .thumbimg img') && !$B(event.target).is('#cp-bullet span') && !$B(event.target).is('#nav-next') && !$B(event.target).is('#nav-prev')){

It will help you.

Share this post


Link to post
Share on other sites