Oleg

Map don't appear

17 posts in this topic

On my local computer in Joomla! 3.4.3 I installed mod_bt_googlemaps_j2.5&j3.x_v2.0.11; published it and insert to article via {loadposition} syntax. The Module Title is showing, but the map don't appear. The 2.0.8 module version work fine.

What is the reason?

Links:

1) http://clip2net.com/s/3n6yOOQ -- very-very strange error,

2) http://clip2net.com/s/3n6yVMz -- code string,

Full page code:


<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en-gb" lang="en-gb" dir="ltr">
<head>
<base href="http://brics-local/en/venue" />
<meta http-equiv="content-type" content="text/html; charset=utf-8" />
<meta name="keywords" content="BRICS summit,Water" />
<meta name="description" content="Scientific Forum as part of the BRICS summit, International scientific-practical conference “Water: equipment, technologies, materials in industry and energetics”" />
<title>Venue - Water: equipment, technologies, materials in industry and energetics</title>
<link href="http://brics-local/ru/venue" rel="alternate" hreflang="ru-RU" />
<link href="http://brics-local/en/venue" rel="alternate" hreflang="en-GB" />
<link href="/templates/olg/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
<link rel="stylesheet" href="http://brics-local/modules/mod_bt_googlemaps/tmpl/css/style.css" type="text/css" />
<link rel="stylesheet" href="/templates/olg/css/style.css" type="text/css" />
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans:300&subset=latin,cyrillic,cyrillic-ext,latin-ext" type="text/css" />
<link rel="stylesheet" href="/media/mod_languages/css/template.css" type="text/css" />
<script src="//maps.google.com/maps/api/js?sensor=true&language=en-GB" type="text/javascript"></script>
<script src="http://brics-local/modules/mod_bt_googlemaps/tmpl/js/btbase64.min.js" type="text/javascript"></script>
<script src="http://brics-local/modules/mod_bt_googlemaps/tmpl/js/default.js" type="text/javascript"></script>
<script src="/media/jui/js/jquery.min.js" type="text/javascript"></script>
<script src="/media/jui/js/jquery-noconflict.js" type="text/javascript"></script>
<script src="/media/jui/js/jquery-migrate.min.js" type="text/javascript"></script>
<script src="/media/system/js/caption.js" type="text/javascript"></script>
<script src="/templates/olg/scripts/respond.min.js" type="text/javascript"></script>
<script type="text/javascript">
jQuery(window).on('load', function() {
new JCaption('img.caption');
});
</script>
<!--[if lt IE 9]><script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<style type="text/css">
div.srm_position {display:none;}
ul.srm_ulmenu {display:block;}
@media screen and (max-width:768px)
{div.srm_position {display:block;}
ul.srm_ulmenu {display:none;} }
</style>
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
</head>
<body>
<div class="container row">
<header class="row logo_fon" role="banner">
<a href="/" title="Water: equipment, technologies, materials in industry and energetics"><img src="/templates/olg/images/en/head.png" /></a> </header>
<div class="middle row gutters">
<div class="col span_3">
<div class="mod-languages zeroleft">
<ul class="lang-inline">
<li class="" dir="ltr">
<a href="/ru/venue">
<img src="/media/mod_languages/images/ru.gif" alt="Русский" title="Русский" /> </a>
</li>
<li class="lang-active" dir="ltr">
<a href="http://brics-local/en/venue">
<img src="/media/mod_languages/images/en.gif" alt="English (UK)" title="English (UK)" /> </a>
</li>
</ul>
</div>
<nav>
<ul class="nav menu srm_ulmenu">
<li class="item-108"><a href="/en/" >About</a></li><li class="item-113 current active"><a href="/en/venue" >Venue</a></li><li class="item-110"><a href="/en/contacts" >Contacts</a></li></ul>
<div class="srm_position" style="top:3px; left:3px; opacity:1;">
<select id="srm_select_list" size="1" style="margin-bottom:0; padding:5px; font-size:1rem; max-width:95%; height:auto;background-color: #E29843;color: #457BB9;" onchange="var e=document.getElementById('srm_select_list'); window.location.href=e.options[e.selectedIndex].value">
<option value="/en/">About</option>
<option value="/en/venue" selected="selected">Venue</option>
<option value="/en/contacts">Contacts</option></select></div>
</nav>
</div>
<section class="col span_9">
<div id="system-message-container">
</div>
<article class="item-page">
<div class="page-header">
<h1> Venue </h1>
</div>




<p>Information and Training Center SUE “Vodokanal of St. Petersburg”, 56 Shpalernaya street, St. Petersburg, Russia</p>
<div class="moduletable">
<h3>Venue_en BT Google Maps</h3>
<script type="text/javascript">window.addEvent('domready', function(){var config = {mapType :'roadmap',width :'auto',height :'350',cavas_id :"cavas_id93", zoom :13,zoomControl :true,scaleControl :true,panControl :true,mapTypeControl :true,streetViewControl :true,overviewMapControl :true,draggable :true,disableDoubleClickZoom :false,scrollwheel :true,weather :0,temperatureUnit :'f',cloud :1,mapCenterType :"coordinate",mapCenterAddress :"Shpalernaya ulitsa, 56 Sankt-Peterburg 191015",mapCenterCoordinate :"59.9487476,30.3745045",enableStyle :"0",styleTitle :"BT Map",createNewOrDefault :"createNew",enableCustomInfoBox :"0",boxPosition :"-150,-155",closeBoxMargin :"-9px",closeBoxImage :"",url:"http://brics-local/"};var boxStyles = {"background":"#ffffff","opacity":" 0.85","width":" 280px","height":"100px","border":" 1px solid grey","borderRadius":"3px","padding":" 10px","boxShadow":"30px 10px 10px 1px grey"};var markersCode ="W3sibWFya2VyVGl0bGUiOiJJbmZvcm1hdGlvbiBhbmQgVHJhaW5pbmcgQ2VudGVyIFNVRSDigJxWb2Rva2FuYWwgb2YgU3QuIFBldGVyc2J1cmfigJ0iLCJtYXJrZXJUeXBlIjoiY29vcmRpbmF0ZSIsIm1hcmtlclZhbHVlIjoiNTkuOTQ4NzQ3NiwzMC4zNzQ1MDQ1IiwibWFya2VySWNvbiI6ImltYWdlcy9qb29tbGFfYmxhY2sucG5nIiwibWFya2VyU2hhZG93SW1hZ2UiOiIiLCJtYXJrZXJTaG93SW5mb1dpbmRvdyI6IjAiLCJtYXJrZXJJbmZvV2luZG93IjoiSW5mb3JtYXRpb24gYW5kIFRyYWluaW5nIENlbnRlciBTVUUg4oCcVm9kb2thbmFsIG9mIFN0LiBQZXRlcnNidXJn4oCdIn1d"; var stylesCode ="W10="; initializeMap(config, markersCode, stylesCode, boxStyles);});</script><div id="cavas_id93" class="bt-googlemaps"></div>
</div>


</article>
</section>
</div>
<footer class="row gutters" role="contentinfo">

</footer>
</div>
</body>
</html>
[/CODE]

Share this post


Link to post
Share on other sites

It is really strange.

I gave you my file, there isn't the javascript function that makes this problem.

But as i see, it still exists.

Do you customize layout of this problem? I mean do you have this file /templates/your_template/html/mod_bt_googlemaps/default.php?

And please try clear cache of joomla.

Share this post


Link to post
Share on other sites

Sorry, please, for my mistake: I forgot about overrides (in overrides was default.php file). I deleted overrides and now module works fine. Thank you very much!

Share this post


Link to post
Share on other sites

Hi Guys,

I am having the same problem I replaced the default,php file on the module but still the map is not showing in the article.

Please help me.

- Calabe

Share this post


Link to post
Share on other sites

Hi John

Thanks so much for using our extensions.

Normally, The Google Map doesn't appear because of javascript error on web page.

So please check if your page has javascript error or give me your URL i will check it for you

Notice the module must be published on the page you give me.

Thanks

Share this post


Link to post
Share on other sites

Hi Christian.

Thanks for using our extension.

I think that reason of this problem is one your plugin.

I see css and js files are minified and compress to one file.

And file google map api javascript file is changed.

So please try to disable this plugin and clear Joomla's cache to check it.

I look forward your news

Thanks

Share this post


Link to post
Share on other sites

Hi,

I have the same problem as others in this thread.

I've tried your updated default.php file, disabled all minification and caching extensions, made sure that there are no javascript errors on the page, but still the map shows up all grey. Any ideas to what else I can try in order to solve this issue?

Best regards,

Share this post


Link to post
Share on other sites

I had same issue. It was my own stylesheet.

To test for yourself use Chome > Inspect (Ctrl + Shift + I) to disable your stylesheet. If your map appears then you need to identify the offending style. For me I'd set a background colour of certain DIVs.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now