konstantinos doulgeridis

Bt smart search doesent show results on search menu item

14 posts in this topic

Hi

First of all i scanned all the forums and tried many things my self but it seems I cant make the results to be shown in my menu item "search" that i have created. Results keep to appear on the same page from where the search started.I cant understand what im doing wrong. site is offline btw

Share this post


Link to post
Share on other sites

Hi there.

I'm sorry but i suspect you choose wrong menu item type.

Are you sure you created menu item for Smart Search?

Because there is other menu item type, it is Search.

Share this post


Link to post
Share on other sites

ok i made some progress my self.I created one more smart search module so now i have smart search module and bt smart search module. I linked the simple smart search module to the menu item.Now when i search i get results in same page again but when i press seach from the second search bar that appers and not from the one that i have in a module position i get transfered to the search menu but if i make a seach from the module position i still get the results into the same page.Any ideas?

Share this post


Link to post
Share on other sites

Hi please try this solution

Open file /modules/mod_bt_smartsearch/helper.php

find this line

$uri = JURI::getInstance(JRoute::_($route));

and change it to

$uri = JURI::getInstance($route);

I hope it will help you.

anamo123 likes this

Share this post


Link to post
Share on other sites

Hi

I have questions.

What element do you want to change its color (text, border ...)?

Do you want to change corner of search box to curved?

All CSS rules are put in file /mod_bt_smartsearch/tmpl/css/form.css

For the search box, its class is .inputboxsearch

You can add property :

border-radius: 3px;

:D

Share this post


Link to post
Share on other sites

Hi.

Please open file /mod_bt_smartsearch/tmpl/default.php

Our developer use PHP code to build the button

$button = '<button type="submit" class="btnsearch" >

<img src="'.$image.'" width="57" height="27" alt="submit" />

</button>';

You can change it to

$button = '<button type="submit" class="btnsearch" >

YOUR_SEARCH_TEXT

</button>';

Then use class .btnsearch to style this button

For example

.btnsearch {

background: #fff;

color: #000;

border-radius: 3px;

border: 1px solid #333;

}

Good luck.

Share this post


Link to post
Share on other sites

I faced this issue too today, with module version 1.0.2..

And the solution posted by Tronghm worked perfectly.

Hi please try this solution

Open file /modules/mod_bt_smartsearch/helper.php

find this line

$uri = JURI::getInstance(JRoute::_($route));

and change it to

$uri = JURI::getInstance($route);

I hope it will help you.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now